Gimpin perusohje

Linux.fi
Loikkaa: valikkoon, hakuun

Gimp on monipuolinen kuvankäsittelyohjelma Linux-käyttöjärjestelmälle. Tässä ohjeessa tutustutaan Gimpin perustoimintoihin, yksinkertaisten muotojen tekemiseen ja väriarvojen muokkaamiseen.

Yleistä[muokkaa]

Tämä ohje käsittelee kuvien käsittelyä ja muokkaamista GIMP-kuvankäsittelyohjelmalla. Ohjeen ensimmäisessä osassa perehdytään ohjelman perustoimintoihin sekä muutamiin hyödyllisiin kuvien muokkaustoimintoihin. Ohjeen soveltamiseksi suositellaan hyvää tietokoneiden perussovellusten käyttötaitoa sekä pientä tuntemusta kuvankäsittelyn perusteista. Ohjeen seuraamista ja oppimista kannattaa kokeilla tekemällä oppaan vaiheita jonkin oman kuvan avulla.

GIMP:n perustoimintoja[muokkaa]

Uuden kuvan tekeminen[muokkaa]

  • Valitaan Tiedosto > Uusi
  • Haluttu kuvakoko voidaan syöttää ikkunan kenttiin tai valita sopiva vaihtoehto malleista. Esimerkissä on valittu valmis mallikoko A4.
1-gimp-perusohje1-uusikuva.png

Värin valitseminen[muokkaa]

Käytössä oleva väri valitaan napsauttamalla värien valintaruutua. Alempi väri on taustaväri ja ylempi käytössä oleva väri.

2-gimp-perusohje1-varinvalinta.png

Zoomaus[muokkaa]

Zoomaus tapahtuu valitsemalla suurennuslasi-työkalu ja napsauttamalla sen jälkeen suurennettavaa kuvaa hiiren painikkeella. Poispäin zoomaus onnistuu samalla tavalla, mutta pitämällä samanaikaisesti Ctrl- näppäintä pohjassa.

GIMP:n piirto- ja kuvankäsittely-ominaisuuksia[muokkaa]

Viivan piirtäminen[muokkaa]

Viivojen piirtäminen GIMP:ssä sisältää omat erikoispiirteensä. Viivojen piirtämistä varten on käytettävissä kaksi työkalua, toinen kovareunaiseen ja toinen siveltimenvetoja muistuttavaan piirtoon.

3-gimp-perusohje1-viivanpiirto.png

Oletuksena molempia voidaan käyttää piirtämään vapaita muotoja.

Suora viiva[muokkaa]

Suoria viivoja molemmilla työkaluilla voidaan piirtää seuraavasti:

  • Valitaan työkaluksi kynä tai sivellin.
  • Painetaan Shift-näppäin pohjaan päästämättä sitä irti.
  • Napsautetaan hiiren ykköspainiketta kohdassa josta halutaan viivan alkavan.
  • Napsautetaan painiketta uudestaan kohdassa johon halutaan viivan päättyvän.
4-gimp-perusohje1-suoraviiva.png

Kaareva viiva[muokkaa]

  • Valitaan polkutyökalu ”Luo ja muokkaa polkuja”.
5-gimp-perusohje1-kaarevaviiva.png
  • Napsautetaan seuraavaksi kohtaan josta halutaan kaarevan viivan alkavan
  • Napsautetaan kohtaa johon haluat sen päättyvän
  • Nyt voidaan tarttua viivasta hiiren kursorilla ja venyttää sitä kaarelle
  • Kun kaari on sopivassa kohtaa napsauta GIMP -ikkunan alaosasta kohtaa ”Piirrä polku”.
  • Valitse haluamasi asetukset ja napsauta ”Piirrä”.

Ympyrän ja neliön piirtäminen[muokkaa]

Ympyrän ja neliön piirtäminen tehdään GIMP:ssä valintatyökalujen avulla. Esimerkissä käsitellään ympyrän tekemistä, mutta sama tekniikka pätee niin neliöille, kuin kädellä Vapaavalinta-työkalulla piirretyille alueillekin.

Täytetty ympyrä[muokkaa]

  • Valitaan ellipsityökalu ”valitse elliptisiä alueita”.
6-gimp-perusohje1-ympyra.png
  • Piirretään halutun kokoinen ympyrä. Painamalla samanaikaisesti Ctrl-näppäin pohjaan voidaan piirtää täydellinen ympyrä.
  • Valitaan väri mikä ympyrään halutaan.
  • Valitse Ämpäri-työkalu.
  • Napsautetaan ympyrävalinnan sisäpuolelle.

Läpinäkyvä ympyrä[muokkaa]

  • Valitaan Taso > Uusi taso
  • Annetaan tasolle nimeksi esim. ympyrät.
  • Valitaan Läpinäkyvä ja napsautetaan OK
  • Valitaan Ellipsi -työkalu
  • Piirretään halutun kokoinen ympyrä. Painamalla samanaikaisesti Ctrl-näppäin pohjaan voidaan piirtää täydellinen ympyrä
  • Valitaan väri millä ympyrän reunat värjätään
  • Valitaan Ämpäri -työkalu
    7-gimp-perusohje1-filltyokalu.png
  • Napsautetaan ympyrävalinnan sisäpuolelle
  • ValitaanValitse > Pienennä
  • Asetetaan montako pikseliä halutaan viivan paksuudeksi ja napsautetaan OK
  • Valitaan Muokkaa > Tyhjennä

Kuvan kirkkauden ja kontrastin muuttaminen[muokkaa]

Kuvien kirkkautta ja tarkkuutta saattaa pystyä parantamaan kontrastia säätämällä. Yleensä epäonnistunutta kuvaa on kuitenkin lähes mahdotonta paikata jälkikäteen. Liian tummaan tai ylivalottuneeseen kuvaan on jälkikäteen lähes mahdotonta saada siitä puuttuvia värejä takaisin. Kontrastin ja kirkkauden muunnosta voi kuitenkin toisinaan käyttää hyvänä tehokeinona kuvia muokatessa.

  • Avataan kuva jonka kirkkautta ja kontrastia halutaan muuttaa.
  • Valitaan Työkalut > Värityökalut > ”Kirkkaus- ja kontrastisäätö...
  • Napsauta Esikatselu-painike päälle, jolloin muutokset näkyvät kuvassa ennen niiden lopullista toteuttamista.
  • Kirkkauden ja kontrastin säätäminen onnistuu avautuvan ikkunan liukusäätimiä liikuttamalla.

Väritasapainon muuttaminen[muokkaa]

Väritasapaino vaikuttaa kuvan selkeyteen ja tunnelmaan ja sen muokkaamiseksi löytyy työkalu ylävalikoista Työkalut > Värityökalut > ”Väritasapainon säätö...”. Väritasapainon säätäminen on hyvin kuvakohtaista, joten parhaiten oikean asetuksen löytää kokeilemalla. Tätä varten kannattaa tarkistaa, että ”Väritasapainon säätö” -ikkunassa on esikatselu kohta valittuna, jolloin tehdyt muutokset näkee heti. Muutokset kuitenkin tallentuvat vasta, kun ikkuna suljetaan painamalla OK. Nollaa-painikkeella tehdyt muutokset kumoutuvat ja Peru-painikkeella nollautumisen lisäksi ikkuna sulkeutuu.

8-gimp-perusohje1-varitasapaino.png

Kuvan rajaaminen[muokkaa]

  • Valitaan GIMP-ikkunan työkaluista ”Rajaa tai muokkaa kuvan kokoa
    9-gimp-perusohje1-rajaustyokalu.png
  • Napsautetaan työkalu valittuna kuvaa, jolloin avautuu ”Rajaa & muokkaa kokoa” -ikkuna
10-gimp-perusohje1-kankaankoko.png
  • Nyt voidaan hiirellä kuvan päällä vetämällä tai ikkunaan numeroarvoja syöttämällä rajata mieleinen kuva-ala
  • Lopuksi napsautetaan ”Rajaa

Jos halutaan että kuvan pituus ja leveys suhteet säilyvät samoina kuin alkuperäisessä, rajaamisen voi tehdä myös seuraavasti.

  • Valitse kuvaikkunan valikoista Kuva > Kankaan koko.
  • Kohdasta kankaan koko määritetään rajattavan alueen suuruus. Pienennetään tätä nuolilla niin, että rajattava alue on sopivan kokoinen. Oletuksena kuvan leveys ja korkeus pienenevät samassa suhteessa, mutta tämän saa tarvittaessa pois napsauttamalla niiden vieressä olevaa ketju-kuvaketta.
    11-gimp-perusohje1-ketjukuvake.png
  • Kohdasta siirtymä siirretään valkoista kehystä jonka sisälle jäävä osa tulee rajattuun kuvaan. Siirrä tämä sopivaan kohtaan.
  • Lopuksi napsautetaan ”Muuta kokoa”. Nyt kuva on rajattu.

Kuvakoon muuttaminen[muokkaa]

Seuraavaksi muutetaan kuvan kokoa eli resoluutiota nettikäyttöön sopivaksi.

  • Valitse Kuva > Skaalaa kuva
  • Avautuneeseen ikkunaan syötetään kuvalle uusi koko
12-gimp-perusohje1-skaalaakuvaa.png

Kuva kokoa on usein kätevä muuttaa suhteellisesti sen nykyiseen kokoon nähden. Tämä onnistuu valitsemalla yksiköiksi kuvan tapaan prosentit. Tämän jälkeen leveydeksi voidaan asettaa esimerkiksi 50 prosenttia ja painaa enter-näppäintä, jolloin tuleva kuvan tarkkuus näkyy korkeus ja leveys asetusten alapuolella.


Tasojen käyttö[muokkaa]

Tasot ovat tärkeä GIMP:n ominaisuus, jolla kuvankäsittelyä voidaan helpottaa ja tehostaa. Tasot ovat ikään kuin päällekkäin olevia kalvoja, jotka voivat olla täysin tai osittain läpinäkyviä/peittäviä. Tasoja on käytännöllistä käyttää esimerkiksi tekstejä lisättäessä, jolloin ne säilyvät liikuteltavina jälkeenpäin. Tasoja käytettäessä on hyvä muistaa, että tasot eivät säily tallennettaessa kuvaa yleisimpiin kuvamuotoihin. Jos halutaan, että tasoja voidaan muokata vielä jälkeenpäin kannattaa kuva tallentaa GIMP:n omassa kuvamuodossa, joka on .xcf. Tämä muoto on tarkoitettu muokattavana säilytettävien kuvien tallentamiseen, joten on suotavaa että kuvan ollessa valmis siitä käytettävä tiedosto olisi tallennettu jossain yleisemmässä muodossa, kuten jpg.

Uuden tason lisääminen[muokkaa]

  • Valitse Taso > Uusi taso. Tällöin avautuu seuraavan näköinen ikkuna
1-gimp-perusohje2-uusitaso.png
  • Anna tasolle nimi
  • Oletuksena tasosta tulee samankokoinen kuin alkuperäisestä kuvasta, mutta tätä voi muuttaa leveys ja korkeus kohdasta
  • Tason täyttötapa määrittää millainen tausta tasolle tulee
  • Taso luodaan napsauttamalla OK

Tasojen hallinta[muokkaa]

Tasojen hallinnassa tärkeänä työkaluna on ylävalikoista löytyvä Ikkunat > Tasot. Sillä voidaan esimerkiksi muuttaa tasojen järjestystä sekä poistaa niitä kokonaan tai ottaa pois näkyvistä.

2-gimp-perusohje2-tasohallinta.png

Aktiivisen tason valinta[muokkaa]

Aktiivisena oleva taso valitaan Ikkunat > Tasot -työkalun avulla napsauttamalla tasoa, joka halutaan aktiiviseksi. Kuvaa muokatessa kannattaa olla tarkkana, että tehtävät muutokset tulevat varmasti sille tasolle jolle on tarkoituskin.

Tason poistaminen[muokkaa]

  • Ota esiin Ikkunat > Tasot
  • Napsauta poistettavaa tasoa hiiren kakkospainikkeella
  • Valitse ”Poista taso”-painike
    3-gimp-perusohje2-roskakorikuvake.png

Tason ottaminen pois näkyvistä[muokkaa]

Taso on mahdollista ottaa pois näkyvistä siten että itse taso kuitenkin säilyy entisellään.

  • Ota esiin Ikkunat > Tasot.
  • Napsauta pois tason vasemmalla oleva silmän kuva.
    4-gimp-perusohje2-silmakuvake.png

Tason saa takaisin näkyviin napsauttamalla silmän kuvaa uudestaan.

Tekstin lisääminen[muokkaa]

Tekstin lisääminen tehdään seuraavasti.

  • Valitse Tekstityökalu
  • GIMP -ikkunasta voit vaihtaa käytettävää fonttia, sen kokoa ja väriä
5-gimp-perusohje2-tekstinlisays.png
  • Napsauta kohtaan johon teksti halutaan lisätä. Tekstityökalu lisää tekstin automaattisesti omalle tasolleen.
  • Kirjoita avautuneeseen tekstieditoriin teksti ja napsauta sulje.
  • Tekstiruutua voidaan siirtää ”Siirrä tasoja ja valintoja” -työkalulla
    6-gimp-perusohje2-siirratasoja.png

Tekstityökalu lisää automaatisesti uuden tekstin omalle tasolleen. Tekstiä voidaan siis siirtää ja muokata jälkeenpäin valitsemalla Ikkunat > Tasot toiminnon avulla taso johon teksti on lisätty.

Suotimien käyttö[muokkaa]

GIMP sisältää useita valmiita suotimia. Suotimilla kuvia voidaan muokata helposti ja asettaa niihin erilaisia tehosteita. Suodinten käyttöön on paras tutustua rohkeasti kokeilemalla ja testaamalla niiden erilaisia tehosteita. Suotimet löytyvät kuvaikkunan ylävalikon kohdasta suotimet.

Suotimen lisääminen[muokkaa]

  • Valitse käytettävä suodin ikkunan Suotimet-valikosta
  • Valitse mahdollisesti avautuvasta ikkunasta tarvittaessa tarkempia asetuksia
  • Napsauta OK

Jos suodinta haluaa käyttää ainoastaan johonkin tiettyyn kohtaan kuvaa, valitse valintatyökaluilla kuvan kohta ja sen ollessa aktiivisena valitse käytettävä suodin.

Suotimen lisäys voidaan tarvittaessa peruuttaa valitsemalla Muokkaa > Kumoa.

Kuvan tallentaminen[muokkaa]

  • Valitse Tiedosto > Tallenna nimellä
  • Etsi tiedostolle sopiva tallennuspaikka
  • Anna tiedostolle nimi, jonka loppuun laitat tiedostomuodon päätteen, jolla kuvan haluat tallentaa (esim. .jpg, .png .xcf). Halutessa että kuvassa säilyvät kaikki tasot erillisinä ja että paras muokattavuus GIMP:ä käyttäessä säilyy kannattaa käyttää .xcf muotoa. Jos kuvaa ei ole enää tarvetta muokata jälkeenpäin kannattaa se tallentaa jossain muussa muodossa. Esimerkiksi jpg sopii hyvin valokuville ja png kaaviokuville.
7-gimp-perusohje2-tallennus.png
  • Napsauta Tallenna-painiketta


Kuvia voidaan tallentaa tietokoneelle monessa eri kuvatiedostomuodossa, joiden ominaisuudet poikkeavat toisistaan. Tässä lyhyessä ohjeessa tarkastellaan kuvien tallennusmuotoja ja kuvamuodon vaihtamista toiseen Gimp-kuvankäsittelyohjelmalla.

Kuvatiedotomuodon muuttaminen Gimpillä[muokkaa]

Kuvia voidaan tallentaa tietokoneelle monessa eri kuvatiedostomuodossa, joiden ominaisuudet poikkeavat toisistaan. Seuraavassa tarkastellaan kuvien tallennusmuotoja ja kuvamuodon vaihtamista toiseen Gimp-kuvankäsittelyohjelmalla.

Tallennusmuodoista[muokkaa]

Tallennusmuodon valintaan vaikuttaa pääasiassa kuvan käyttötarkoitus ja kohde. Seuraavassa on lueteltu yleisimmät kuvien tallennusmuodot, niiden suositeltava käyttötarkoitus ja muutamia yleisiä ominaisuuksia.

JPG - Tämä on hyvä tallennusmuoto esimerkiksi valokuville. Jpg-muoto on yleisesti avattavissa kaikissa tietokonejärjestelmissä ja se soveltuu hyvin internetissä esitettävien kuvien tallennusmuodoksi. Jpg-tiedoston hyvänä puolena on sen vähän tilaa vievä tallennuskoko, mutta siinä käytetty pakkaus heikentää hieman kuvan laatua kuvaoriginaaliin verrattuna.

PNG - Erityisesti kaaviokuville ja kuvaajille sopiva muoto. Png muotoinen kuvatiedosto on yleisesti avattavissa kaikissa tietokonejärjestelmissä ja se sopii internet-käyttöön. PNG ei heikennä kuvan laatua verrattuna alkuperäiseen, mutta se vie huomattavasti enemmän tilaa jpg-muotoon verrattuna, erityisesti jos sitä käytetään esimerkiksi valokuvien tallentamiseen.

XCF - Gimpin kuvankäsittely tiedostomuoto jota kannattaa käyttää tallennettaessa omia kuvan muokkausprojekteja. Xcf-muoto vie paljon tilaa ja samalla tallentuvat kaikki kyseisen projektin asetukset, kuvien tasot ja muut projektiin liittyvät tiedot. Xcf-muoto on yleensä avattavissa ainoastaan Gimpillä.

Tallennusmuodon muuttaminen[muokkaa]

GIMP pystyy käsittelemään useita kymmeniä eri tallennusmuotoja, joiden välillä muunnoksia voidaan tehdä. Seuraavassa esitellään tiedostotyypin muuttamisen perusajatus vaiheittain.

  • Valitse Tiedosto > Avaa...
  • Valitse kuva jonka tallennusmuotoa halutaan muuttaa.
  • Valitse avautuneesta kuvaikkunasta Tiedosto > Tallenna nimellä...
  • Anna tiedostolle nimi
1-gimp-tallentaminen-tiedostonnimi.png
  • Napsauta kohdan Tiedoston tyyppi vieressä olevasta pienestä kolmiosta.
2-gimp-tallentaminen-tiedostomuoto.png
  • Valitse napsauttamalla tiedostotyyppiä johon haluat kuvan muuttaa.
  • Napsauta Tallenna-painiketta.