LV2

Kohteesta Linux.fi
Versio hetkellä 8. syyskuuta 2013 kello 23.40 – tehnyt Heikkiket (keskustelu | muokkaukset) (Perustiedot LV2-plugineista)
(ero) ← Vanhempi versio | Nykyinen versio (ero) | Uudempi versio → (ero)
Siirry navigaatioon Siirry hakuun

LV2 on laajennettu versio vanhasta LADSPA-pluginstandardista. Se on suunniteltu alunperin Linux-käyttöön, eikä ole ainakaan vielä sanottavasti levinnyt Linux-maailman ulkopuolelle. LV2 on modulaarinen plugin-teknologia, mikä tarkoittaa että sitä voidaan jatkuvasti laajentaa uusilla ominaisuuksilla. Tämä tekee LV2:sta myös hivenen tempukkaan tukea: pluginia lataavan ohjelman pitää tukea kaikkia pluginin vaatimia LV2-laajennuksia, jotta plugin toimii kunnolla. LV2-tuki ei siis sinänsä vielä tarkoita, että ohjelma tukee kaikkia LV2-plugineja. Käytännössä kuitenkin LV2 on hyvin tuettu nykyisten Linux-musiikinteko-ohjelmien joukossa.

LV2:n suurimmat edistysaskeleet Ladspa-plugineihin verrattuna ovat graafinen käyttöliittymä ja mahdollisuus toteuttaa syntetisaattoreita.

LV2-pluginien asentaminen

Kuten muutkin pluginit, myös LV2:t jaetaan Linuxissa .so-tiedostoina, ja ne pitää kopioida määrättyyn kansioon, josta ohjelmat osaavat niitä etsiä.

  • /usr/lib/lv2 – paketinhallinnan kautta asennetut pluginit.
  • /usr/local/lib/lv2 – muualta asennetut pluginit.
  • ~/.lv2 – käyttäjäkohtaiset pluginit. Ei vaadi pääkäyttäjän oikeuksia.

Järkevintä on asentaa järjestelmänlaajuiset pluginit /usr/local/lib/lv2 -kansioon ja omaan käyttöön tarkoitetut pluginit kotikansion alaisuudessa olevaan .lv2-[[piilotiedosto | piilokansioon].

LV2-plugineja

LV2 on vasta muutaman vuoden vanha standardi, mutta jo nyt plugineja löytyy melkoinen määrä.

  • Calf-pluginit löytyvät LV2-versioina. Sekä efektejä että syntetisaattoreita.
  • Invada-pluginit sisältävät käyttökelpoisia efektejä
  • Loomer tekee hienoja kaupallisia LV2-plugineja.
  • LinuxDSP tekee LV2-efektiplugineja.
  • VocProc pitch shifting LV2